PHP is de meest gebruikte programmeertaal op het Web. Volgens W3Techs wordt PHP door bijna 79% van alle websites gebruikt. Zo is het onder meer de taal waarin WordPress is geschreven, maar ook Magento, Joomla en Drupal. Sinds dit weekend is dan ook de laatste versie van PHP 7.4 bij Kyzoe beschikbaar. Op iets meer dan twee weken hebben we alle servers klaargestoomd voor PHP 7.4.

Upgraden wordt aangeraden!

Upgraden naar de laatste versie van PHP is altijd aan te raden. Die voorziet niet alleen verbeteringen in de beveiligingen maar is ook weer een pak sneller dan de vorige versie. Natuurlijk moet je bij het upgraden van je PHP versie wel uitkijken of je applicatie ook werkt met de laatste versie. Dat is namelijk niet altijd het geval.

Hoe gaat het upgraden in zijn werk:

Een nieuwe versie van PHP in gebruik nemen op de servers van Kyzoe Hosting is relatief makkelijk:

  • Log hiervoor in op je hosting controlepaneel: https://uwdomeinnaam.be:2222/
  • Klik op ‘select php version’ onder extra features.
  • Daarna kies je in het dropdown menu voor 7.4.
  • Test je website.

Werkt je website niet met PHP 7.4 dan kan je op dezelfde wijze ook de PHP versie terug zetten naar de vorige versie.

PHP 5.6 is OUD – Upgraden is noodzakelijk!!!

Bij gebruikers van het WordPress CMS maar ook bij andere gebruikers zien we dat nog altijd bijna 25% op een PHP versie draait die stokoud is en door PHP niet meer onderhouden wordt: versie 5.6. Naast het feit dat PHP versie 5.6 oud is, sluipen er ook beveiligings problemen in en is het ook nog eens een pak trager dan PHP 7.3 of 7.4.

Bij maar liefst 52,4% van alle websites die op PHP draaien zien we dat ze nog op PHP 5 draaien! En dat terwijl:

  • PHP 5.2 maar liefst 400% trager is dan PHP 7
  • Bij PHP 7 het systeem twee keer zoveel requests kan uitvoeren in vergelijking met PHP 5.6, met bijna de helft van de latency
  • PHP 7.4 minder geheugen verbruikt dan PHP 7.3

WordPress gebruikers zijn hierin niet veel beter. Nog maar 12% draait op PHP 7.3, en nog altijd meer dan 23% draait nog op PHP 5.6 volgens de recente WordPress statistieken. UPGRADEN DUS. 

MAAR LET OP!!!

Controleer op voorhand of je plug-ins en thema’s wel mee kunnen, Dat kan je natuurlijk het best eerst even op een (clone) staging site testen die je weer kan aanmaken via Installatron. Mocht je hier hulp bij nodig hebben dan helpen we je graag. Wil je er helemaal geen omkijken naar, mail ons dan op [email protected] en vraag naar ons onderhoudspakket.

 

Laat een reactie achter